SPOJ Problem Set (classical)

42. Adding Reversed Numbers

Problem code: ADDREV

The Antique Comedians of Malidinesia prefer comedies to tragedies. Unfortunately, most of the ancient plays are tragedies. Therefore the dramatic advisor of ACM has decided to transfigure some tragedies into comedies. Obviously, this work is very hard because the basic sense of the play must be kept intact, although all the things change to their opposites. For example the numbers: if any number appears in the tragedy, it must be converted to its reversed form before being accepted into the comedy play.

Reversed number is a number written in arabic numerals but the order of digits is reversed. The first digit becomes last and vice versa. For example, if the main hero had 1245 strawberries in the tragedy, he has 5421 of them now. Note that all the leading zeros are omitted. That means if the number ends with a zero, the zero is lost by reversing (e.g. 1200 gives 21). Also note that the reversed number never has any trailing zeros.

ACM needs to calculate with reversed numbers. Your task is to add two reversed numbers and output their reversed sum. Of course, the result is not unique because any particular number is a reversed form of several numbers (e.g. 21 could be 12, 120 or 1200 before reversing). Thus we must assume that no zeros were lost by reversing (e.g. assume that the original number was 12).

Input

The input consists of N cases (equal to about 10000). The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly one line with two positive integers separated by space. These are the reversed numbers you are to add.

Output

For each case, print exactly one line containing only one integer - the reversed sum of two reversed numbers. Omit any leading zeros in the output.

Example

Sample input: 

3
24 1
4358 754
305 794

Sample output:

34
1998
1

All Submissions
Best Solutions


Point Value: 5
Time Limit: 2.00s
Memory Limit: 16M
Added: Apr 08, 2011

Languages Allowed:
C++03, PAS, C, HASK, ASM, RUBY, PYTH2, JAVA, PHP, SCM, CAML, PERL, C#, C++11, PYTH3

Comments (Search)

Any hints to test case 2? The IRC help server is empty...

Ask your question in IRC, wait, then check the logs for an answer after a few hours. Or use the forum.

It says that you've been idle since Sun May 19 19:43:04 2013.

And nobody else is ever on. Where should we ask questions?

"Idle" just means I haven't typed anything in. Which makes sense, since there are no questions to reply to.

the problem says that the problem code is ADDREV but on the submission page it says the problem code is b2 which one is correct?

Use b2 as the problem code.

it always gives an error
can u please send me the rest of the error msg :O

It looks like
input()
doesn't work properly on the Judge. Use
int(raw_input())
in this case instead.

What is the highest number that could possibly be for the 2 numbers we have to add together. And will the sum be a longint?

Nvm, you don't need that variable for this question

um Saravannan and Joyce are we allowed to use what Jim is telling me to use?

I used it but I don't think you need to.


It was a bug in the test cases. It's fixed.

Aww...now that the test cases are fixed, my program doesn't work! I'll have to redo it.

Yeah, lol. Lot of other ppl have to do that too, such as Ben.